Thema: Heizung/Klima IHKA- Tipps zur Überholung
Einzelnen Beitrag anzeigen
Alt 22.03.2020, 11:47   #3
Erich
Erfahrenes Mitglied
 
Benutzerbild von Erich
 
Registriert seit: 19.07.2002
Ort: Joso
Fahrzeug: E32 750iL 11/88, E36M3 02/98 Motor S52USB32
Standard

da hat ja jemand eine Verbesserung gemacht mit einen kleinen Kuehlventilator, siehe hier, 2.4 MB zum runterladen
Externer Link (&Ooml;ffnet in neuem Fenster, der Forumsbetreiber distanziert sich vom Inhalt extern verlinkter Seiten.) http://www.e32-schrauber.de/bmw/date...difikation.pdf
Text kopiert:
Umbau des IHKA-Steuergerätes (E32) wegen Überhitzung

Das Problem war ein Ausfall des IHKA-Steuergerätes immer nach ca. 1 Stunde Fahrzeit. In kaltem Zustand funktionierte sie tadellos. Die wahrscheinliche Ursache ist eine Überhitzung des gesamten Steuergerätes. Das Gehäuse ist vollständig verschlossen und auf der Platine befinden sich einige Bauteile, die erhebliche Wärme produzieren. Als Abhilfe wurde eine aktive Lüftung eingebaut. Die Ausschnitte befinden sich über den Komponenten mit der größten Hitzeentwicklung. Die zwei Lüfter (30x30x7) wurden in die „Stufe“ des Gehäuses eingebaut, darunter ist ausreichend Abstand zu den elektronischen Bauteilen.
Der elektische Anschluss
Am oberen Ende der Platine findet man die +12V (KL 15) und Masse auf zwei dicht beieinander liegenden dickeren Leiterbahnen. Hier wurde ein Stecker aufgelötet (vorher natürlich die Leiterbahn vom Schutzlack befreien bis blankes Kupfer zu sehen ist…).
Die Lüfter werden über 5 in Serie geschaltete Dioden (1N4001 o.ä.) von +12V versorgt. Im Betrieb sind das dann ca. 10V (13,8V – 5 x 0,7V), damit laufen sie deutlich leiser als mit den vollen 14V. Zum Test wurden die Temperaturen an zwei Stellen (Kühlblech links – Temp 1; Widerstand rechts – Temp 2) gemessen. Bis ca. 4400 Sek. (1 ¼ h) lief das Steuergerät im Leerlauf – nur 13,8V angelegt, kein Schalten, keine Stepper, nichts – aber 65°C am Widerstand! Dann wurden die Lüfter eingeschaltet… Zusatz-Infos über das IHKA-Steuergerät: Während ich mich mit den möglichen Ursachen des Fehlers rumschlug, versuchte ich, mehr über den Aufbau der IHKA herauszubringen. Leider sind wesentliche Bauteile (Mikrocontroller, Treiber,…) kodiert beschriftet – hier war leider nichts mit absoluter Sicherheit heraus zu bringen. Daher: alle folgenden Infos basieren auf meinen eigenen verworrenen Gedanken, wie das Steuergerät wohl aufgebaut sein mag… (Bild und Übersicht am Ende des Dokuments)

Das IHKA-Steuergerät ist diagnosefähig, d.h. (fast) alle Ströme /Spannungen werden gemessen und überwacht. Hierfür sind die Leistungswiderstände zusammen mit den LM2901 zuständig, welche analoge Werte (Soll / Ist) vergleichen und ein entsprechendes digitales Signal an den Hauptcontroller geben. Dies kann auch zum Problem werden, da jeder Wert, der nicht in den festgelegten Grenzen liegt, eine Fehlermeldung auslöst. Und wenn im Laufe der Jahre ein paar Werte weglaufen, kann es zu Fehlern kommen, die gar keine sind…Die Schrittmotoren werden mit 4 Phasen gegen Masse geschaltet (ULN2003’s). Das entsprechende Bitmuster wird vom SchrittmotorController in den Schieberegistern (HEF4094) gespeichert, die genau damit die ULN2003’s ansteuern. Für die Wasserventile etc. sind zwei Treiber-IC’s eingebaut (leider codiert: L475D). Und hier liegt eines der großen Rätsel: neben diesen Treibern befinden sich zwei 120-Ohm-Leistungswiderstände. Diese liegen aber nicht zwecks Strommessung o.ä. in einem Massepfad,sondern werden einfach nur bestromt – eine Heizung! Warum und wieso: keine Ahnung… Ich kenne nur einen Grund, warum man so etwas macht: durch eine solche „sinnlose“ Last zieht das Steuergerät auch im Ruhezustand einen definierten Strom und kann somit vom Bordnetz erkannt werden. Nur: genau diese Widerstände werden ordentlich heiß! Auf allen Bildern im Netz sieht man, dass die Platinen in diesem Bereich schön braun gebrutzelt sind… Deshalb habe ich genau hier die Öffnungen ins Gehäuse gefräst. Ein weiterer Hitze-Kandidat ist der PTC des Innenfühler-Lüfterchens. Ein PTC wirkt wie eine Sicherung. Normal hat er einen geringen Widerstand und lässt Strom fließen. Fließt zuviel Strom (z.B.: Kurzschluss), wird er heiß und hochohmig – es fließt kaum noch Strom. Das Problem: wenn er durch das heiße Gehäuse „von außen“ beheizt wird, wird er auch hochohmig und der Controller bekommt den Fehler gemeldet: „Kurzschluss im Lüfterkreis“. Das könnte das wesentliche Problem bei dem Steuergerät sein… Dann ist da noch der Haupt-Schalt-Transistor. Er sitzt auf dem gleichen Kühlblech wie der 5V-Spannungsregler für die digitale Elektronik. Der Transistor schaltet innerhalb des Steuergerätes die KL30-Versorgung (Dauerplus) auf die interne KL15 (geschaltetes Plus). Damit kann die Steuerung die oft zitierten 2 Minuten nachlaufen und wird erst dann ausgeschaltet. Hier wieder ein Problem: der Haupt-Transistor selbst wird über Hilfs-Transistoren eingeschaltet. Letztere sind besagte BC337. Wenn diese mal durchbrennen, bekommt der Haupt-Transistor immer Strom und schaltet damit das Steuergerät nie aus – und die Batterie ist schnell leer (…sie muss ja dauernd die 120-Ohm-Heizung betreiben…). Der Haupt-Controller ist aller Wahrscheinlichkeit nach aus der Motorola 6805-Familie. Einige der Pins sind auf der Platine mit Sicherheit zu bestimmen (Versorgung, Quarz, etc.). Interessant war hier der ResetEingang – dieser führt zu einem der LM2901. Dieser Schaltungsteil war im Originalzustand dermaßen heikel, dass die Schaltung nicht aus dem Reset herauskam, wenn ich einen der Eingänge des LM2901 mit der Oszilloskopspitze berührte (!). Nach dem Tausch der „umliegenden“ Kondensatoren war dieses Phänomen verschwunden…Wenn das IHKA-Steuergerät schon offen ist und ein Lötkolben bereit steht, dann würde ich die BC337’s tauschen und die Kondensatoren, die sich rund ums das Kühlblech befinden (2 x Elko, 2 x Tantal).
Erich ist offline   Antwort Mit Zitat antworten